summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/curb/curb-0.8.6.ebuild')
-rw-r--r--dev-ruby/curb/curb-0.8.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/curb/curb-0.8.6.ebuild b/dev-ruby/curb/curb-0.8.6.ebuild
new file mode 100644
index 000000000000..2d65ffd49fce
--- /dev/null
+++ b/dev-ruby/curb/curb-0.8.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/curb/curb-0.8.6.ebuild,v 1.1 2014/07/23 05:24:26 graaff Exp $
+
+EAPI=5
+# No longer compatible with ruby 1.8
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby-language bindings for libcurl"
+HOMEPAGE="http://curb.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" net-misc/curl[ssl]"
+RDEPEND+=" net-misc/curl[ssl]"
+
+all_ruby_prepare() {
+ # fix tests when localhost is also ::1
+ sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
+
+ # avoid tests making outside network connections
+ rm tests/bug_postfields_crash.rb || die
+ sed -e '/test_easy_http_verbs_must_respond_to_str/askip "needs network"' \
+ -i tests/tc_curl_easy.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
+ cp -l ext/curb_core$(get_modname) lib || die
+}