summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/insight/insight-6.0.ebuild')
-rw-r--r--dev-util/insight/insight-6.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/insight/insight-6.0.ebuild b/dev-util/insight/insight-6.0.ebuild
new file mode 100644
index 000000000000..2c20d2c6872e
--- /dev/null
+++ b/dev-util/insight/insight-6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.0.ebuild,v 1.1 2003/10/29 17:32:10 plasmaroo Exp $
+
+IUSE="nls"
+
+DESCRIPTION="A graphical interface to the GNU debugger"
+HOMEPAGE="http://sources.redhat.com/insight/index.html"
+LICENSE="GPL-2 LGPL-2"
+DEPEND="virtual/x11
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha"
+SRC_URI="ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+INSIGHTDIR="/opt/insight"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure --prefix="${INSIGHTDIR}" \
+ --mandir="${D}${INSIGHTDIR}/share/man" \
+ --infodir="${D}${INSIGHTDIR}/share/info" \
+ ${myconf} || die
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ prefix="${D}${INSIGHTDIR}" \
+ mandir="${D}${INSIGHTDIR}/share/man" \
+ infodir="${D}${INSIGHTDIR}/share/info" \
+ install || die
+ insinto /etc/env.d
+ doins "${FILESDIR}/99insight"
+
+}