summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.3.2.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.3.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.3.2.ebuild b/dev-vcs/hg-git/hg-git-0.3.2.ebuild
new file mode 100644
index 000000000000..f13febf585a6
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.3.2.ebuild,v 1.1 2012/02/12 12:18:31 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="push and pull from a Git server using Mercurial"
+HOMEPAGE="http://hg-git.github.com/ http://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-vcs/mercurial-1.9
+ >=dev-python/dulwich-0.8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_MODNAME="hggit"