summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/xevil/xevil-2.02_p2.ebuild')
-rw-r--r--games-arcade/xevil/xevil-2.02_p2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/xevil/xevil-2.02_p2.ebuild b/games-arcade/xevil/xevil-2.02_p2.ebuild
new file mode 100644
index 000000000000..fc4716aadb56
--- /dev/null
+++ b/games-arcade/xevil/xevil-2.02_p2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xevil/xevil-2.02_p2.ebuild,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+inherit games
+
+MY_PV=${PV/_p/r}
+DESCRIPTION="3rd person, side-view, fast-action, kill-them-before-they-kill-you game"
+HOMEPAGE="http://www.xevil.com/"
+SRC_URI="http://www.xevil.com/download/stable/xevilsrc${MY_PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ edos2unix readme.txt
+ sed -i \
+ -e 's:-static::' \
+ -e "s:CFLAGS=\":CFLAGS=\"${CFLAGS} :g" \
+ -e 's:-lXpm:-lXpm -lpthread:g' \
+ config.mk
+}
+
+src_compile() {
+ make || die #emake dies horribly
+}
+
+src_install() {
+ dogamesbin x11/REDHAT_LINUX/xevil
+ newgamesbin x11/REDHAT_LINUX/serverping xevil-serverping
+ dodoc readme.txt
+ prepgamesdirs
+}