summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gnocatan/gnocatan-0.7.1-r3.ebuild')
-rw-r--r--games-board/gnocatan/gnocatan-0.7.1-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-board/gnocatan/gnocatan-0.7.1-r3.ebuild b/games-board/gnocatan/gnocatan-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..78e2d2db6dd6
--- /dev/null
+++ b/games-board/gnocatan/gnocatan-0.7.1-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.7.1-r3.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+# http://gnocatan.sourceforge.net/ is terribly outdated
+HOMEPAGE="http://www.sourceforge.net/projects/gnocatan/"
+SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1*
+ =dev-libs/glib-1*
+ gnome-base/gnome-libs
+ >=sys-apps/sed-4
+ gnome-base/ORBit
+ sys-devel/patch"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s/term1.dccs.com.au/gnocatan.debian.net/" ${S}/common/meta.h || \
+ die "sed meta.h failed"
+ epatch ${FILESDIR}/gnocatan-wijnen-patch.diff
+}
+
+src_compile() {
+ econf `use_enable nls` || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README
+}