summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xscrabble/xscrabble-2.10.ebuild')
-rw-r--r--games-board/xscrabble/xscrabble-2.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-board/xscrabble/xscrabble-2.10.ebuild b/games-board/xscrabble/xscrabble-2.10.ebuild
new file mode 100644
index 000000000000..d4e92b2145b3
--- /dev/null
+++ b/games-board/xscrabble/xscrabble-2.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xscrabble/xscrabble-2.10.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="An X11 clone of the well-known Scrabble"
+HOMEPAGE="http://freshmeat.net/projects/xscrabble/?topic_id=80"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/educational_games/${P}.tgz
+ nls? ( ftp://ftp.ac-grenoble.fr/ge/educational_games/xscrabble_fr.tgz )
+ ftp://ftp.ac-grenoble.fr/ge/educational_games/xscrabble_en.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nls"
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${P}.tgz
+
+ cp ${DISTDIR}/xscrabble_en.tgz .
+ [ `use nls` ] && cp ${DISTDIR}/xscrabble_fr.tgz .
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-path-fixes.patch
+}
+
+src_compile() {
+ ./build bin || die
+}
+
+src_install() {
+ export DESTDIR=${D}
+ ./build install || die
+ [ `use nls` ] && { ./build lang fr || die; }
+ ./build lang en || die
+ for f in ${D}/usr/X11R6/lib/X11/app-defaults/* ; do
+ sed -i "s:/usr/games/lib/scrabble/:${GAMES_DATADIR}/${PN}/:" ${f}
+ done
+ dodoc CHANGES README
+ prepgamesdirs
+}