summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 21e9911f70d6..8453cd49fbdc 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-9999.ebuild,v 1.1 2013/08/26 04:24:59 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-9999.ebuild,v 1.2 2013/08/26 07:19:36 twitch153 Exp $
EAPI=5
@@ -12,10 +12,10 @@ if [[ ${PV} == 9999* ]]
then
EGIT_REPO_URI="https://code.google.com/p/dolphin-emu/"
inherit git-2
- KEYWORKD=""
+ KEYWORDS=""
else
SRC_URI="http://${PN}-emu.googlecode.com/files/${P}-src.zip"
- KEYWORDS="~amd"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Dolphin is a Gamecube and Wii game emulator"
@@ -51,9 +51,18 @@ DEPEND="${RDEPEND}
x11-libs/wxGTK:2.9
"
-src_prepare() {
+pkg_pretend() {
+
+ local ver=4.6.0
+ local msg="${PN} needs at least GCC ${ver} set to compile."
+
+ if ! version_is_at_least ${ver} $(gcc-fullversion); then
+ eerror ${msg}
+ die ${msg}
+ fi
+}
- version_is_at_least 4.6.0 $(gcc-fullversion) || die "${PN} needs >=gcc-4.6.0 set to compile."
+src_prepare() {
# Remove automatic dependencies to prevent building without flags enabled.
if use !alsa; then