summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/yabause/yabause-0.6.0.ebuild')
-rw-r--r--games-emulation/yabause/yabause-0.6.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-emulation/yabause/yabause-0.6.0.ebuild b/games-emulation/yabause/yabause-0.6.0.ebuild
new file mode 100644
index 000000000000..fe0e7d7471eb
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.6.0.ebuild,v 1.1 2005/12/27 18:43:12 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="http://yabause.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE="gtk"
+
+RDEPEND="gtk? ( =x11-libs/gtk+-2* )
+ virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ media-libs/sdl-image"
+DEPEND="${RDEPEND}
+ gtk? ( dev-util/pkgconfig )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ egamesconf $(use_with gtk) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog TODO README
+ prepgamesdirs
+}