summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/frotz/frotz-2.43.ebuild')
-rw-r--r--games-engines/frotz/frotz-2.43.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-engines/frotz/frotz-2.43.ebuild b/games-engines/frotz/frotz-2.43.ebuild
index dbc1922b962a..55aa0703221e 100644
--- a/games-engines/frotz/frotz-2.43.ebuild
+++ b/games-engines/frotz/frotz-2.43.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/frotz-2.43.ebuild,v 1.18 2010/10/04 12:38:22 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/frotz-2.43.ebuild,v 1.19 2010/10/04 14:59:19 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -14,23 +14,23 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE="alsa oss"
-RDEPEND="sys-libs/ncurses
+DEPEND="sys-libs/ncurses
alsa? ( oss? ( media-libs/alsa-oss ) )"
-DEPEND="${RDEPEND}"
src_prepare() {
sed -i \
-e '/^CC /d' \
Makefile \
- || die 'sed failed'
- epatch "${FILESDIR}"/${P}-glibc2.10.patch \
+ || die
+ epatch \
+ "${FILESDIR}"/${P}-glibc2.10.patch \
"${FILESDIR}"/${P}-ldflags.patch
}
src_compile() {
local OPTS="CONFIG_DIR=${GAMES_SYSCONFDIR}"
- use oss && OPTS="${MAKE_OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
- emake ${MAKE_OPTS} all || die "emake failed"
+ use oss && OPTS="${OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
+ emake ${OPTS} all || die "emake failed"
}
src_install () {