summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/alephone/files/alephone-20061228-configure.patch')
-rw-r--r--games-fps/alephone/files/alephone-20061228-configure.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-fps/alephone/files/alephone-20061228-configure.patch b/games-fps/alephone/files/alephone-20061228-configure.patch
new file mode 100644
index 000000000000..5d58d039d67b
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20061228-configure.patch
@@ -0,0 +1,38 @@
+--- configure.ac
++++ configure.ac
+@@ -15,6 +15,8 @@
+
+ dnl Configure options.
+ AC_ARG_ENABLE(opengl, [ --enable-opengl use OpenGL for rendering [default=yes]], , enable_opengl=yes)
++AC_ARG_ENABLE(lua, , , enable_lua=yes)
++AC_ARG_ENABLE(speex, , , enable_speex=yes)
+
+ dnl Checks for programs.
+ AC_PROG_CC
+@@ -98,6 +100,7 @@
+ ])
+ ])
+
++if [[ "x$enable_lua" = "xyes" ]]; then
+ dnl Check for Lua.
+ AC_ARG_VAR(LUA_CFLAGS, [C compiler flags for Lua])
+ AC_ARG_VAR(LUA_LIBS, [linker flags for Lua])
+@@ -124,14 +127,17 @@
+ AC_DEFINE(HAVE_LUA_H, 1, [Assuming <lua.h> is present])
+ AC_DEFINE(HAVE_LUALIB_H, 1, [Assuing <lualib.h> is present])
+ fi
++fi
+
++if [[ "x$enable_speex" = "xyes" ]]; then
+ dnl Check for Speex
+-AC_CHECK_HEADERS(speex.h, [
++AC_CHECK_HEADERS(speex/speex.h, [
+ AC_CHECK_LIB(speex, speex_decoder_init, [
+ LIBS="-lspeex $LIBS"
+ AC_DEFINE(SPEEX, 1, [Speex support is enabled])
+ ])
+ ])
++fi
+
+ dnl Figure out which OpenGL library to use
+ case "$target" in