summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild')
-rw-r--r--games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild b/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild
index 5daf7c192b29..7100a8ec4fca 100644
--- a/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild
+++ b/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild,v 1.6 2006/03/22 21:52:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild,v 1.7 2006/03/27 18:43:12 wolf31o2 Exp $
inherit eutils games
@@ -61,7 +61,7 @@ src_install() {
for pk3 in baseq3/*.pk3 missionpack/*.pk3 ; do
dosym ${GAMES_DATADIR}/quake3/${pk3} ${dir}/${pk3}
done
- dosym ${GAMES_DATADIR}/quake3/pak0.pk3 ${dir}/baseq3/pak0.pk3
+ dosym ${GAMES_DATADIR}/quake3/baseq3/pak0.pk3 ${dir}/baseq3/pak0.pk3
dosym ${GAMES_DATADIR}/quake3/missionpack/pak0.pk3 \
${dir}/missionpack/pak0.pk3
else
@@ -87,23 +87,17 @@ src_install() {
newconfd "${FILESDIR}"/q3ded.conf.d q3ded
fi
newicon quake3.xpm quake3-bin.xpm
+ make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3-bin.xpm
prepgamesdirs
- make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3-bin.xpm
}
pkg_postinst() {
games_pkg_postinst
- echo
ewarn "There are two possible security bugs in this package, both causing a"
ewarn "denial of service. One affects the game when running a server, the"
ewarn "other when running as a client."
ewarn "For more information, please see bug #82149."
- if ! use cdinstall ; then
- echo
- einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
- einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
- fi
if use dedicated; then
echo
einfo "To start a dedicated server, run"