summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild')
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
index f5fda3984aeb..f448b39b837e 100644
--- a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
+++ b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.9 2010/10/08 08:34:50 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.10 2011/11/16 16:01:11 darkside Exp $
-EAPI=2
+EAPI=3
inherit eutils toolchain-funcs
DESCRIPTION="The notorious fortune program"
@@ -11,7 +11,7 @@ SRC_URI="http://www.redellipse.net/code/downloads/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="offensive elibc_glibc"
DEPEND="app-text/recode"
@@ -29,20 +29,29 @@ src_prepare() {
Makefile || die "sed Makefile failed"
if ! use elibc_glibc ; then
- local reglibs="-lcompat"
+ [[ ${CHOST} == *-*bsd* ]] && local reglibs="-lcompat"
+ [[ ${CHOST} == *-darwin* ]] && local reglibs="-lc"
has_version "app-text/recode[nls]" && reglibs="${reglibs} -lintl"
sed -i \
-e "/^REGEXLIBS=/s:=.*:= ${reglibs}:" \
Makefile \
|| die "sed REGEXLIBS failed"
fi
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's:u_int:uint:g' util/strfile.h || die "sed strfile.h failed"
+ fi
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/-DBSD_REGEX/-DPOSIX_REGEX/' Makefile || die "sed Makefile failed"
+ fi
}
src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+ local myrex=
+ [[ ${CHOST} == *-interix* ]] && myrex="REGEXDEFS=-DNO_REGEX"
+ emake CC="$(tc-getCC)" $myrex || die "emake failed"
}
src_install() {
- emake prefix="${D}" install || die "emake install failed"
+ emake prefix="${ED}" install || die "emake install failed"
dodoc ChangeLog INDEX Notes Offensive README TODO cookie-files
}