summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/icebreaker/icebreaker-1.9.6.ebuild')
-rw-r--r--games-puzzle/icebreaker/icebreaker-1.9.6.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild b/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
index 246169fcc72f..c90a01c54ebd 100644
--- a/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
+++ b/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild,v 1.2 2013/06/24 20:45:12 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild,v 1.3 2015/01/06 18:56:45 mr_bones_ Exp $
EAPI=5
inherit eutils games
@@ -18,10 +18,13 @@ RDEPEND="media-libs/libsdl[video]
media-libs/sdl-mixer"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-ldflags.patch
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-parallell-install.patch
- "${FILESDIR}"/${P}-ovfl.patch )
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-parallell-install.patch \
+ "${FILESDIR}"/${P}-ovfl.patch
+}
src_compile() {
emake \