summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/dragonhunt')
-rw-r--r--games-rpg/dragonhunt/Manifest2
-rw-r--r--games-rpg/dragonhunt/dragonhunt-3.55.ebuild78
2 files changed, 0 insertions, 80 deletions
diff --git a/games-rpg/dragonhunt/Manifest b/games-rpg/dragonhunt/Manifest
index d97fe7a9df47..cf73345d6db9 100644
--- a/games-rpg/dragonhunt/Manifest
+++ b/games-rpg/dragonhunt/Manifest
@@ -1,6 +1,4 @@
-DIST Dragon_Hunt-3.55.tar.gz 2159851 RMD160 963dc739d4e464a323acee3f7325713ddb4cb12d SHA1 68d7dbbb0690c23d0c57e8bf03919ecaa70fa6a5 SHA256 d7d73b3ab7aa1c3e91b0221d3759e7da7d07f7569f3d201a00d54624259c84d0
DIST Dragon_Hunt-3.56.tar.gz 2170718 RMD160 82199f84e20a3620e223a3488129f34a7f2de01e SHA1 1ed23a5ef8dcad0bf1f66dcb89475224b07a2c52 SHA256 70a22937fd002f2d82d8998623b6ec101fadfbafc4e0d1857aa0686c6bf1eba9
-EBUILD dragonhunt-3.55.ebuild 2167 RMD160 987b2a6b04ecaeb8b36ee47c120c10d401cbd762 SHA1 b8d8165884ba85a50fab49df8920efcbdc1a02d1 SHA256 afe7728f3cc677de39b577c096d91d223bda414386978fefa09078be6f5ec0cd
EBUILD dragonhunt-3.56.ebuild 2332 RMD160 042d6b757d3d1b1f2c9077742b712d094d92b771 SHA1 3655c91823fc18e9794ce965f1b2d09d66ca2b26 SHA256 9251f6636abc6a88f74e5511a5c35836e617634d1d8908535fecb7f65abe0818
MISC ChangeLog 469 RMD160 3620be8bbd5808280185f255aa9216a99ce636f3 SHA1 32e9decd3bd89c7c79fe5a84b61c20bea2349b3a SHA256 aaeb6d224198bce1c7ce2dbdb3d485a48c5f7f997fbcc8db7cc3520c60020f65
MISC metadata.xml 159 RMD160 5f925ed2fa3718b7d5cdc3f2a12866d3e516bacc SHA1 cd24812821185c81f7c05255d3fa66f5399daaa6 SHA256 c3c3613f26371d08a639f099b4f0d23f1efa7477c4414784a274edfd853eeec7
diff --git a/games-rpg/dragonhunt/dragonhunt-3.55.ebuild b/games-rpg/dragonhunt/dragonhunt-3.55.ebuild
deleted file mode 100644
index e06ca26219b3..000000000000
--- a/games-rpg/dragonhunt/dragonhunt-3.55.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/dragonhunt/dragonhunt-3.55.ebuild,v 1.2 2007/04/05 01:46:12 nyhm Exp $
-
-inherit games
-
-MY_P="Dragon_Hunt-${PV}"
-DESCRIPTION="A simple graphical RPG."
-HOMEPAGE="http://emhsoft.com/dh.html"
-SRC_URI="http://emhsoft.com/dh/${MY_P}.tar.gz"
-
-LICENSE="GPL-2 CCPL-ShareAlike-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-lang/python
- dev-python/pygame"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Where to look for modules to load.
- sed -i -e "s:\.\./modules/:${GAMES_DATADIR}/${PN}/:" \
- code/g.py \
- code/map_editor.py \
- code/rpg.py \
- || die "Could not change module path."
-
- # Where to look for keybinding
- sed -i -e "s:\.\./settings:${GAMES_SYSCONFDIR}/${PN}/settings:" \
- code/g.py \
- || die "Could not change settings.txt directory"
-
- # Save games in ~/.${PN}/.
- sed -i \
- -e "s:^\(from os import.*\):\1\, environ:" \
- -e "s:g.mod_dir.*\"/saves/\?\":environ[\"HOME\"] + \"/.${PN}/\":" \
- code/g.py code/loadgame.py \
- || die "Could not change savegames location."
-
- # Save maps in ~/.
- sed -i \
- -e "s:^\(from os import.*\):\1\, environ:" \
- -e "s:g.mod_dir.*\"map\.txt\":environ[\"HOME\"]\ +\ \"/dh_map.txt\":" \
- code/map_editor.py \
- || die "Could not change map location."
-}
-
-src_install() {
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r modules/* || die "doins modules failed"
-
- insinto "${GAMES_SYSCONFDIR}"/${PN}
- doins settings.txt || die "doins settings.txt failed"
-
- insinto "$(games_get_libdir)"/${PN}
- doins code/*.py || die "doins code failed"
-
- games_make_wrapper ${PN} "python ./rpg.py" "$(games_get_libdir)"/${PN}
- games_make_wrapper ${PN}-mapeditor "python ./map_editor.py" "$(games_get_libdir)"/${PN}
-
- dodoc README.txt docs/{Changelog,Items.txt,example_map.txt,tiles.txt}
- dohtml docs/*.html
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "If you use the map editor then note that maps will be saved as"
- elog "~/dh_map.txt and must be move to the correct module directory"
- elog "(within ${GAMES_DATADIR}/${PN}) by hand."
- echo
-}