summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freelords/freelords-0.3.7.ebuild')
-rw-r--r--games-strategy/freelords/freelords-0.3.7.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/games-strategy/freelords/freelords-0.3.7.ebuild b/games-strategy/freelords/freelords-0.3.7.ebuild
index 27a99c473c93..f8b36a1c2174 100644
--- a/games-strategy/freelords/freelords-0.3.7.ebuild
+++ b/games-strategy/freelords/freelords-0.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.7.ebuild,v 1.1 2006/03/26 09:48:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.7.ebuild,v 1.2 2006/03/29 19:40:55 mr_bones_ Exp $
inherit eutils games
@@ -14,6 +14,7 @@ SLOT="0"
IUSE="editor nls"
RDEPEND="dev-libs/expat
+ media-libs/sdl-mixer
>=media-libs/libsdl-1.2
>=media-libs/sdl-image-1.2
>=media-libs/freetype-2
@@ -24,6 +25,13 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
dev-util/pkgconfig"
+pkg_setup() {
+ if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
+ die "Please emerge sdlmixer with USE=vorbis"
+ fi
+ games_pkg_setup
+}
+
src_unpack() {
unpack ${A}
cd "${S}"