summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin/dolphin-4.2.0.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.2.0.ebuild b/kde-base/dolphin/dolphin-4.2.0.ebuild
new file mode 100644
index 000000000000..0b86c5dca9f9
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.2.0.ebuild,v 1.1 2009/01/27 16:29:04 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase"
+KMMODULE="apps/${PN}"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook +semantic-desktop"
+
+DEPEND="
+ >=kde-base/libkonq-${PV}:${SLOT}
+ kde-base/kdelibs:${SLOT}[semantic-desktop=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT} )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_configure
+}