summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin/dolphin-4.4.0-r1.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.4.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.4.0-r1.ebuild b/kde-base/dolphin/dolphin-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..5c640bedf964
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.4.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.4.0-r1.ebuild,v 1.1 2010/02/26 23:30:21 mrpouet Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook semantic-desktop subversion thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ subversion? (
+ dev-util/subversion
+ $(add_kdebase_dep kompare) )
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? ( $(add_kdebase_dep mplayerthumbs) )
+"
+
+KMLOADLIBS="libkonq"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use subversion; then
+ sed -e '/install(.*fileviewsvnplugin.*)/s/^/#DONOTINSTALL /g' \
+ -i dolphin/src/CMakeLists.txt || die 'failed to disable subversion plugin'
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}