summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kaboodle/kaboodle-3.4.1.ebuild')
-rw-r--r--kde-base/kaboodle/kaboodle-3.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/kaboodle/kaboodle-3.4.1.ebuild b/kde-base/kaboodle/kaboodle-3.4.1.ebuild
new file mode 100644
index 000000000000..e76bf73c8c00
--- /dev/null
+++ b/kde-base/kaboodle/kaboodle-3.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaboodle/kaboodle-3.4.1.ebuild,v 1.1 2005/05/25 21:23:00 danarmak Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The Lean KDE Media Player"
+KEYWORDS="~x86 ~amd64"
+IUSE="xine audiofile"
+
+OLDRDEPEND="
+ ~kde-base/kdemultimedia-arts-$PV
+ ~kde-base/artsplugin-mpeglib-$PV
+ ~kde-base/artsplugin-mpg123-$PV
+ xine? ( ~kde-base/artsplugin-xine-$PV )
+ audiofile? ( ~kde-base/artsplugin-audiofile-$PV )"
+RDEPEND="$(deprange $PV $MAXKDEVER kde-base/kdemultimedia-arts)
+ $(deprange $PV $MAXKDEVER kde-base/artsplugin-mpeglib)
+ $(deprange $PV $MAXKDEVER kde-base/artsplugin-mpg123)
+ xine? ( $(deprange $PV $MAXKDEVER kde-base/artsplugin-xine) )
+ audiofile? ( $(deprange $PV $MAXKDEVER kde-base/artsplugin-audiofile) )"
+
+KMEXTRACTONLY="arts/"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+} \ No newline at end of file