summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/magneto-kde/magneto-kde-1.0_rc80.ebuild')
-rw-r--r--kde-misc/magneto-kde/magneto-kde-1.0_rc80.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-misc/magneto-kde/magneto-kde-1.0_rc80.ebuild b/kde-misc/magneto-kde/magneto-kde-1.0_rc80.ebuild
new file mode 100644
index 000000000000..c7dc6b695f69
--- /dev/null
+++ b/kde-misc/magneto-kde/magneto-kde-1.0_rc80.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/magneto-kde-1.0_rc80.ebuild,v 1.1 2011/12/22 17:56:36 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet KDE frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ kde-base/pykde4
+ dev-python/PyQt4[dbus]"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-kde-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/kde"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/kde"
+}