summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.2-r3.ebuild')
-rw-r--r--media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.2-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.2-r3.ebuild b/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.2-r3.ebuild
new file mode 100644
index 000000000000..ab511519c83e
--- /dev/null
+++ b/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.2-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.2-r3.ebuild,v 1.1 2004/06/15 18:33:35 wolf31o2 Exp $
+
+IUSE="livecd"
+S=${WORKDIR}/livecd-${PV}
+DESCRIPTION="Gentoo ${PV} theme for bootsplash consoles"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${PF}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/livecd/${PF}.tar.bz2"
+
+SLOT=${PV}
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+
+DEPEND=">=media-gfx/bootsplash-0.6-r16"
+
+src_install() {
+ dodir /etc/bootsplash/livecd-${PV}
+ cp -r ${S}/* ${D}/etc/bootsplash/livecd-${PV}
+
+ # link default config for livecd images if USE=livecd set
+ use livecd \
+ && cd ${D}/etc/bootsplash \
+ && rm default \
+ && dosym ./livecd-${PV} /etc/bootsplash/default
+}