summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/povray/povray-3.50c.ebuild')
-rw-r--r--media-gfx/povray/povray-3.50c.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-gfx/povray/povray-3.50c.ebuild b/media-gfx/povray/povray-3.50c.ebuild
index 76f94b23bae1..43e59fa2ca5a 100644
--- a/media-gfx/povray/povray-3.50c.ebuild
+++ b/media-gfx/povray/povray-3.50c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.50c.ebuild,v 1.2 2003/03/26 20:30:58 malverian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.50c.ebuild,v 1.3 2003/03/30 20:06:02 mholzer Exp $
IUSE="icc X svga"
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.povray.org/"
SLOT="0"
LICENSE="povlegal-3.5"
KEYWORDS="x86 ppc alpha"
-
+inherit gcc
DEPEND="media-libs/libpng
sys-libs/zlib
@@ -20,6 +20,15 @@ DEPEND="media-libs/libpng
icc? ( dev-lang/icc )
svga? ( media-libs/svgalib )"
+pkg_setup() {
+
+ if [ "$(gcc-version)" != "3.2" ]
+ then
+ eerror "This build needs gcc-3.2 or later"
+ die
+ fi
+}
+
src_compile() {
econf || die