summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/jpeg/jpeg-7.ebuild')
-rw-r--r--media-libs/jpeg/jpeg-7.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/media-libs/jpeg/jpeg-7.ebuild b/media-libs/jpeg/jpeg-7.ebuild
index f5f904c4078f..2fee8b58d636 100644
--- a/media-libs/jpeg/jpeg-7.ebuild
+++ b/media-libs/jpeg/jpeg-7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-7.ebuild,v 1.3 2009/08/22 12:16:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-7.ebuild,v 1.4 2009/08/23 00:52:55 vapier Exp $
-EAPI=2
-inherit eutils libtool toolchain-funcs
+EAPI="2"
+inherit eutils libtool
DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
HOMEPAGE="http://www.ijg.org/"
@@ -15,13 +15,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
src_prepare() {
epatch "${FILESDIR}"/${P}-maxmem_sysconf.patch
elibtoolize
+
+ # hook the extra dir into the normal jpeg build env
+ mv ../${P}-extra extra
+ sed -i '/all:/s:$:\n\t$(MAKE) -C extra $@:' Makefile.in
+ # newer extra tarball has this integrated
+ cd extra
+ sed -e 's:mandir:man1dir:' Makefile > Makefile.in
+ grep ' = @' ../Makefile.in >> Makefile.in
+ printf 'all %%:\n\t../config.status --file=Makefile:Makefile.in\n\t$(MAKE) $@' > Makefile
}
src_configure() {
@@ -32,16 +37,7 @@ src_configure() {
--enable-maxmem=64
}
-src_compile() {
- emake || die "emake failed"
- tc-export CC
- emake -C "${WORKDIR}"/${P}-extra || die "emake failed"
-}
-
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- emake -C "${WORKDIR}"/${P}-extra DESTDIR="${D}" \
- install || die "emake install failed"
-
- dodoc example.c README *.{log,txt} || die "dodoc failed"
+ emake DESTDIR="${D}" install || die
+ dodoc example.c README *.{log,txt}
}