summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alsa-tools/alsa-tools-1.0.23.ebuild')
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.0.23.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.23.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.23.ebuild
index c73c71c9320d..e7e110fe0245 100644
--- a/media-sound/alsa-tools/alsa-tools-1.0.23.ebuild
+++ b/media-sound/alsa-tools/alsa-tools-1.0.23.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.23.ebuild,v 1.8 2011/01/22 22:56:27 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.23.ebuild,v 1.9 2011/03/20 20:13:16 jlec Exp $
+EAPI=1
inherit eutils flag-o-matic autotools
MY_P="${P/_rc/rc}"
DESCRIPTION="Advanced Linux Sound Architecture tools"
-HOMEPAGE="http://www.alsa-project.org"
+HOMEPAGE="http://www.alsa-project.org/"
SRC_URI="mirror://alsaproject/tools/${MY_P}.tar.bz2"
LICENSE="GPL-2"
@@ -27,8 +28,8 @@ ${ECHOAUDIO_CARDS}"
RDEPEND=">=media-libs/alsa-lib-1.0.22
>=dev-python/pyalsa-1.0.22
- fltk? ( =x11-libs/fltk-1.1* )
- gtk? ( =x11-libs/gtk+-2* )"
+ fltk? ( x11-libs/fltk:1 )
+ gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -102,8 +103,8 @@ src_unpack() {
src_compile() {
if use fltk; then
# hdspmixer requires fltk
- append-ldflags "-L/usr/$(get_libdir)/fltk-1.1"
- append-flags "-I/usr/include/fltk-1.1"
+ append-ldflags "-L$(dirname $(fltk-config --libs))"
+ append-flags "-I$(fltk-config --includedir)"
fi
local f