summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lame/lame-3.96.1-r1.ebuild')
-rw-r--r--media-sound/lame/lame-3.96.1-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-sound/lame/lame-3.96.1-r1.ebuild b/media-sound/lame/lame-3.96.1-r1.ebuild
index 5d1bc5bfff57..019070fdd95a 100644
--- a/media-sound/lame/lame-3.96.1-r1.ebuild
+++ b/media-sound/lame/lame-3.96.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.96.1-r1.ebuild,v 1.5 2006/05/26 17:51:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.96.1-r1.ebuild,v 1.6 2006/07/05 06:52:05 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils autotools
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="gtk debug"
RDEPEND=">=sys-libs/ncurses-5.2
@@ -20,20 +20,20 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S} || die
+ cd "${S}"
# The frontened tries to link staticly, but we prefer shared libs
- epatch ${FILESDIR}/${P}-shared-frontend.patch
+ epatch "${FILESDIR}"/${P}-shared-frontend.patch
# If ccc (alpha compiler) is installed on the system, the default
# configure is broken, fix it to respect CC. This is only
# directly broken for ARCH=alpha but would affect anybody with a
# ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
- epatch ${FILESDIR}/${PN}-3.96-ccc.patch
+ epatch "${FILESDIR}"/${PN}-3.96-ccc.patch
# Seems like lame devs uses a custom config.h.in that doesn't support
# largefiles, add a patch to fix that.
- epatch ${FILESDIR}/${P}-largefile.patch
+ epatch "${FILESDIR}"/${P}-largefile.patch
# Make sure -lm is linked in the library to fix other programs linking to
# this while using --as-needed
@@ -72,5 +72,5 @@ src_install() {
dodoc API ChangeLog HACKING PRESETS.draft README* STYLEGUIDE TODO USAGE
dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
- dobin ${S}/misc/mlame
+ dobin "${S}"/misc/mlame || die
}