summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999-r1.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999-r1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999-r1.ebuild b/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
index 073e8545c9e1..55295d0de926 100644
--- a/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999-r1.ebuild,v 1.4 2009/06/10 09:08:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999-r1.ebuild,v 1.5 2009/07/03 19:31:42 aballier Exp $
EAPI=2
@@ -12,13 +12,14 @@ DESCRIPTION="Complete solution to record, convert and stream audio and video.
Includes libavcodec. live svn"
HOMEPAGE="http://ffmpeg.org/"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="+3dnow +3dnowext alsa altivec amr cpudetection custom-cflags debug dirac
doc ieee1394 +encode faac faad gsm ipv6 jack +mmx +mmxext vorbis test
- theora threads x264 xvid network zlib sdl X mp3 oss schroedinger
- +hardcoded-tables bindist v4l v4l2 speex +ssse3 jpeg2k"
+ theora threads x264 xvid network zlib sdl X mp3 opencore-amrnb
+ opencore-amrwb oss schroedinger +hardcoded-tables bindist v4l v4l2
+ speex +ssse3 jpeg2k"
RDEPEND="sdl? ( >=media-libs/libsdl-1.2.10 )
alsa? ( media-libs/alsa-lib )
@@ -36,6 +37,8 @@ RDEPEND="sdl? ( >=media-libs/libsdl-1.2.10 )
dirac? ( media-video/dirac )
gsm? ( >=media-sound/gsm-1.0.12-r1 )
jpeg2k? ( >=media-libs/openjpeg-1.3-r2 )
+ opencore-amrnb? ( media-libs/opencore-amr )
+ opencore-amrwb? ( media-libs/opencore-amr )
schroedinger? ( media-libs/schroedinger )
speex? ( >=media-libs/speex-1.2_beta3 )
jack? ( media-sound/jack-audio-connection-kit )
@@ -95,10 +98,9 @@ src_configure() {
use threads && myconf="${myconf} --enable-pthreads"
# Decoders
- use faad && myconf="${myconf} --enable-libfaad"
- use dirac && myconf="${myconf} --enable-libdirac"
- use schroedinger && myconf="${myconf} --enable-libschroedinger"
- use speex && myconf="${myconf} --enable-libspeex"
+ for i in faad dirac schroedinger speex opencore-amrnb opencore-amrwb ; do
+ use $i && myconf="${myconf} --enable-lib$i"
+ done
use jpeg2k && myconf="${myconf} --enable-libopenjpeg"
if use gsm; then
myconf="${myconf} --enable-libgsm"
@@ -141,7 +143,7 @@ src_configure() {
done
# Mandatory configuration
- myconf="${myconf} --enable-gpl --enable-postproc \
+ myconf="${myconf} --enable-gpl --enable-version3 --enable-postproc \
--enable-avfilter --enable-avfilter-lavf \
--disable-stripping"