summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vmaid/vmaid-2.2.4.ebuild')
-rw-r--r--media-video/vmaid/vmaid-2.2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-video/vmaid/vmaid-2.2.4.ebuild b/media-video/vmaid/vmaid-2.2.4.ebuild
new file mode 100644
index 000000000000..570b71e55e66
--- /dev/null
+++ b/media-video/vmaid/vmaid-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/vmaid-2.2.4.ebuild,v 1.1 2014/10/27 17:18:12 mrueg Exp $
+
+EAPI=5
+
+DESCRIPTION="Video maid is the AVI file editor"
+HOMEPAGE="http://vmaid.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/vmaid/48081/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao mime"
+
+RDEPEND="x11-libs/gtk+:2
+ ao? ( media-libs/libao )
+ !ao? ( alsa? ( >=media-libs/alsa-lib-0.9 ) )
+ mime? ( x11-misc/shared-mime-info )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ app-text/scrollkeeper"
+
+src_configure() {
+ econf \
+ $(use_enable mime) \
+ --with-ao=$(usex ao) \
+ --with-alsa=$(usex alsa) \
+ --without-w32
+}
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README
+ dohtml -r doc/{en,ja}
+}