summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mtr/mtr-0.73.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-0.73.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/net-analyzer/mtr/mtr-0.73.ebuild b/net-analyzer/mtr/mtr-0.73.ebuild
deleted file mode 100644
index c34c402e2114..000000000000
--- a/net-analyzer/mtr/mtr-0.73.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.73.ebuild,v 1.1 2008/05/18 12:21:59 cedk Exp $
-
-inherit flag-o-matic autotools eutils
-
-DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
-HOMEPAGE="http://www.bitwizard.nl/mtr/"
-SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="gtk ipv6"
-
-RDEPEND="sys-libs/ncurses
- gtk? ( >=x11-libs/gtk+-2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-am_path_gtk.patch"
- eautoreconf
-}
-
-src_compile() {
- local myconf
- use gtk || myconf="${myconf} --without-gtk"
-
- [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
-
- econf ${myconf} \
- $(use_enable gtk gtk2) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # this binary is universal. ie: it does both console and gtk.
- emake DESTDIR="${D}" sbindir=/usr/bin install || die "make install failed"
-
- insinto /usr/share/${PN}
- doins img/mtr_icon.xpm
-
- fowners root:wheel /usr/bin/mtr
- fperms 4710 /usr/bin/mtr
-
- dodoc AUTHORS ChangeLog FORMATS NEWS README SECURITY TODO
-}