summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/siphon/siphon-666.ebuild')
-rw-r--r--net-analyzer/siphon/siphon-666.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/siphon/siphon-666.ebuild b/net-analyzer/siphon/siphon-666.ebuild
new file mode 100644
index 000000000000..a346abaf25ec
--- /dev/null
+++ b/net-analyzer/siphon/siphon-666.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/siphon/siphon-666.ebuild,v 1.1 2003/10/20 18:40:10 port001 Exp $
+
+IUSE=""
+MY_P=${PN}-v.${PV}
+
+DESCRIPTION="A portable passive network mapping suite"
+SRC_URI="http://siphon.datanerds.net/${MY_P}.tar.gz"
+HOMEPAGE="http://siphon.datanerds.net/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ sed -i "s:osprints\.conf:/etc/osprints.conf:" log.c
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin siphon
+ insinto /etc
+ doins osprints.conf
+ dodoc LICENSE README
+}
+