summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/trafshow/trafshow-3.1.ebuild')
-rw-r--r--net-analyzer/trafshow/trafshow-3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/trafshow/trafshow-3.1.ebuild b/net-analyzer/trafshow/trafshow-3.1.ebuild
new file mode 100644
index 000000000000..3ca85f8322b5
--- /dev/null
+++ b/net-analyzer/trafshow/trafshow-3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Aubrey Kilian <aubrey@ebe.uct.ac.za>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafshow/trafshow-3.1.ebuild,v 1.1 2002/02/16 17:09:51 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Full screen visualization of the network traffic"
+SRC_URI="ftp://ftp.nsk.su/pub/RinetSoftware/${P}.tgz"
+HOMEPAGE="http://soft.risp.ru/trafshow/index_en.shtml"
+
+DEPEND="net-libs/libpcap"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=\${prefix}/share/man \
+ --enable-ipv6 || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+}