summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/firestarter/firestarter-0.8.2.ebuild')
-rw-r--r--net-firewall/firestarter/firestarter-0.8.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-firewall/firestarter/firestarter-0.8.2.ebuild b/net-firewall/firestarter/firestarter-0.8.2.ebuild
new file mode 100644
index 000000000000..18188460a976
--- /dev/null
+++ b/net-firewall/firestarter/firestarter-0.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/firestarter-0.8.2.ebuild,v 1.1 2003/02/09 16:50:08 mholzer Exp $
+
+IUSE="nls"
+
+#MY_P=firestarter-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="Gui for firewalls (iptables & ipchains), and a firewall monitor."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://firestarter.sf.net"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.1.4
+ <gnome-base/gnome-panel-2
+ sys-apps/iptables"
+RDEPEND="nls? ( sys-devel/gettext )"
+SLOT="0"
+
+src_compile() {
+
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ einstall destdir=${D} graphicsdir=${D}/usr/share/pixmaps || die "einstall failed"
+ dodoc AUTHORS Changelog README TODO
+
+}
+
+pkg_postinstall() {
+ ./postinstall
+}