summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/ftpcube/ftpcube-0.4.3-r1.ebuild')
-rw-r--r--net-ftp/ftpcube/ftpcube-0.4.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-ftp/ftpcube/ftpcube-0.4.3-r1.ebuild b/net-ftp/ftpcube/ftpcube-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..fc41830ab7c0
--- /dev/null
+++ b/net-ftp/ftpcube/ftpcube-0.4.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.4.3-r1.ebuild,v 1.1 2004/01/12 20:53:26 pythonhead Exp $
+
+IUSE=""
+
+inherit distutils virtualx
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Graphical FTP client using wxPython"
+SRC_URI="mirror://sourceforge/ftpcube/${P}.tar.gz"
+HOMEPAGE="http://ftpcube.sourceforge.net/"
+DEPEND="virtual/python
+ >=dev-python/wxPython-2.4.0.2"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 ~sparc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+ sed -i -e "s/EVT_KILL_FOCUS/#EVT_KILL_FOCUS/" ${S}/libftpcube/connectwin.py ||
+ die "sed failed on connectwin.py"
+}
+
+src_compile() {
+ export maketype=distutils_src_compile
+ virtualmake
+}
+
+src_install() {
+ export maketype=distutils_src_install
+ virtualmake
+}