summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild b/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild
index eed115e75def..bab8a1b89d52 100644
--- a/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild,v 1.1 2006/07/22 16:33:49 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild,v 1.2 2006/08/13 19:33:47 uberlord Exp $
inherit flag-o-matic eutils
@@ -28,11 +28,14 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # Redefine the location of ntp.drift
- sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
+ # Never take the interface down
+ epatch "${FILESDIR}/${PN}-2.0.8-alwaysup.patch"
epatch "${FILESDIR}/${P}-loglevel.patch"
epatch "${FILESDIR}/${P}-no_resolve_hostname.patch"
+
+ # Redefine the location of ntp.drift
+ sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
}
src_compile() {