summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/mldonkey/mldonkey-2.5.12.ebuild')
-rw-r--r--net-p2p/mldonkey/mldonkey-2.5.12.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/net-p2p/mldonkey/mldonkey-2.5.12.ebuild b/net-p2p/mldonkey/mldonkey-2.5.12.ebuild
new file mode 100644
index 000000000000..dd8e2b90e440
--- /dev/null
+++ b/net-p2p/mldonkey/mldonkey-2.5.12.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.5.12.ebuild,v 1.1 2004/02/16 16:06:20 mholzer Exp $
+
+inherit eutils
+
+IUSE="gtk"
+
+MY_P=${P//./-}
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="mldonkey is a new client to access the eDonkey network. It is written in Objective-Caml, and comes with its own GTK GUI, an HTTP interface and a telnet interface."
+HOMEPAGE="http://www.nongnu.org/mldonkey/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+
+DEPEND="gtk? ( =dev-ml/lablgtk-1.2.5 )
+ >=dev-lang/ocaml-3.06
+ dev-lang/perl"
+RDEPEND="net-misc/wget"
+
+MLUSER="p2p"
+
+src_compile() {
+ use gtk || export GTK_CONFIG="no"
+
+ # the dirs are not (yet) used, but it doesn't hurt to specify them anyway
+ econf \
+ --sysconfdir=/etc/mldonkey \
+ --sharedstatedir=/var/mldonkey \
+ --localstatedir=/var/mldonkey \
+ --enable-ocamlver=3 \
+ --enable-batch
+
+ # ocalm 3.07 fix
+ sed -i -e"s:format:format4:g" src/utils/lib/autoconf.ml
+
+ emake || die
+}
+
+src_install() {
+ dobin mlnet
+ use gtk && dobin mlchat mlgui mlguistarter mlim mlnet+gui
+ dobin ${FILESDIR}/mldonkey
+
+ dodoc ChangeLog Copying.txt Developers.txt Install.txt
+ cd ${S}/distrib
+ dodoc Authors.txt Bugs.txt Readme.txt Todo.txt ed2k_links.txt
+ dohtml FAQ.html
+
+ insinto /usr/share/doc/${PF}/scripts
+ doins kill_mldonkey mldonkey_command mldonkey_previewer
+
+ insinto /usr/share/doc/${PF}/distrib
+ doins directconnect.ini servers.ini
+
+ cd ${S}/docs
+ dodoc *.txt *.tex *.pdf
+ dohtml *.html
+
+ cd ${S}/docs/developers
+ dodoc *.txt *.tex
+
+ cd ${S}/docs/images
+ insinto /usr/share/doc/${PF}/html/images
+ doins *
+
+ insinto /etc/conf.d; newins ${FILESDIR}/mldonkey.confd mldonkey
+ exeinto /etc/init.d; newexe ${FILESDIR}/mldonkey.initd mldonkey
+
+ # add user
+ enewuser ${MLUSER} -1 /bin/bash /home/p2p users
+}
+
+pkg_postinst() {
+ echo
+ einfo "Running \`mldonkey' will start the server inside ~/.mldonkey/"
+ einfo "If you want to start mldonkey in a particular working directory,"
+ einfo "use the \`mlnet' command."
+ einfo "If you want to start mldonkey as a system service, use"
+ einfo "the /etc/init.d/mldonkey script. To control bandwidth, use"
+ einfo "the 'slow' and 'fast' arguments. Be sure to have a look at"
+ einfo "/etc/conf.d/mldonkey also."
+ echo
+}