summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-1.0.0_beta3_p1149.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.0.0_beta3_p1149.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-1.0.0_beta3_p1149.ebuild b/net-p2p/qbittorrent/qbittorrent-1.0.0_beta3_p1149.ebuild
new file mode 100644
index 000000000000..e8d38dc17e5b
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.0.0_beta3_p1149.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.0.0_beta3_p1149.ebuild,v 1.1 2007/08/01 21:44:56 armin76 Exp $
+
+inherit eutils qt4
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/rb_libtorrent-0.13_pre1415
+ $(qt4_min_version 4.2)
+ >=dev-lang/python-2.3
+ dev-libs/boost
+ net-misc/curl
+ dev-cpp/commoncpp2"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/lib \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}