summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/rtorrent/rtorrent-0.9.1.ebuild')
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/net-p2p/rtorrent/rtorrent-0.9.1.ebuild b/net-p2p/rtorrent/rtorrent-0.9.1.ebuild
deleted file mode 100644
index e75b1857f030..000000000000
--- a/net-p2p/rtorrent/rtorrent-0.9.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.1.ebuild,v 1.4 2014/05/18 19:58:08 swift Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="BitTorrent Client using libtorrent"
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="daemon debug ipv6 selinux test xmlrpc"
-
-COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
- >=dev-libs/libsigc++-2.2.2:2
- >=net-misc/curl-7.19.1
- sys-libs/ncurses
- selinux? ( sec-policy/selinux-rtorrent )
- xmlrpc? ( dev-libs/xmlrpc-c )"
-RDEPEND="${COMMON_DEPEND}
- daemon? ( app-misc/screen )"
-DEPEND="${COMMON_DEPEND}
- test? ( dev-util/cppunit )
- virtual/pkgconfig"
-
-src_prepare() {
- # bug #358271
- epatch "${FILESDIR}"/${P}-ncurses.patch
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_with xmlrpc xmlrpc-c)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS README doc/rtorrent.rc
-
- if use daemon; then
- newinitd "${FILESDIR}/rtorrentd.init" rtorrentd || die "newinitd failed"
- newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd || die "newconfd failed"
- fi
-}