summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/ipw3945d/ipw3945d-1.7.22-r2.ebuild')
-rw-r--r--net-wireless/ipw3945d/ipw3945d-1.7.22-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-wireless/ipw3945d/ipw3945d-1.7.22-r2.ebuild b/net-wireless/ipw3945d/ipw3945d-1.7.22-r2.ebuild
new file mode 100644
index 000000000000..0ce2c3480708
--- /dev/null
+++ b/net-wireless/ipw3945d/ipw3945d-1.7.22-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.22-r2.ebuild,v 1.1 2006/09/05 19:37:59 phreak Exp $
+
+inherit eutils
+
+DESCRIPTION="Regulatory daemon for the Intel PRO/Wireless 3945ABG miniPCI express adapter"
+HOMEPAGE="http://www.bughost.org/ipw3945/"
+SRC_URI="http://www.bughost.org/ipw3945/daemon/${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND=""
+
+pkg_setup() {
+ enewgroup ipw3945d
+ enewuser ipw3945d -1 -1 -1 ipw3945d
+}
+
+src_install() {
+ into /
+ use x86 && dosbin x86/ipw3945d
+ use amd64 && dosbin x86_64/ipw3945d
+
+ keepdir /var/run/${PN}
+ fowners ipw3945d:ipw3945d /var/run/${PN}
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+
+ dodoc README.${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The ipw3945d is now started using an init script. To automatically have"
+ einfo "it started, you need to add it to the boot run level as shown below:"
+ einfo
+ einfo " # rc-update add ${PN} default"
+ einfo
+
+ if [[ -e "${ROOT}"/etc/modules.d/ipw3945d ]]; then
+ ewarn
+ ewarn "You need to manually delete the now obsolete modprobe entry and run"
+ ewarn "modules-update as shown below:"
+ ewarn
+ ewarn " # rm -f ${ROOT}/etc/modules.d/ipw3945d; modules-update --force"
+ ewarn
+ fi
+}