summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/straw/straw-0.22.1.ebuild')
-rw-r--r--net-www/straw/straw-0.22.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-www/straw/straw-0.22.1.ebuild b/net-www/straw/straw-0.22.1.ebuild
index 74fd50758f25..aa44ec2a6ed0 100644
--- a/net-www/straw/straw-0.22.1.ebuild
+++ b/net-www/straw/straw-0.22.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.22.1.ebuild,v 1.3 2004/03/30 09:16:58 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.22.1.ebuild,v 1.4 2004/04/09 23:05:17 liquidx Exp $
inherit gnome2 python distutils
@@ -27,6 +27,14 @@ RDEPEND="${DEPEND}
# pre 0.22 straw databases. It should be removed at some point.
# foser <foser@gentoo.org> 18 Feb 2004
+pkg_setup() {
+ if ! python -c 'import gtk; import gtkhtml2'; then
+ eerror "The gnome-python gtkhtml2 module was not found."
+ eerror "Rebuild gnome-python using:"
+ eerror " USE=\"gtkhtml\" emerge gnome-python"
+ die "missing gtkhtml2 python module"
+ fi
+}
src_install() {