summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gnucap/gnucap-20050220.ebuild')
-rw-r--r--sci-electronics/gnucap/gnucap-20050220.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-electronics/gnucap/gnucap-20050220.ebuild b/sci-electronics/gnucap/gnucap-20050220.ebuild
new file mode 100644
index 000000000000..a628b34d7793
--- /dev/null
+++ b/sci-electronics/gnucap/gnucap-20050220.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-20050220.ebuild,v 1.1 2005/03/25 23:38:33 plasmaroo Exp $
+
+inherit eutils
+
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6}"
+
+DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
+SRC_URI="http://geda.seul.org/dist/gnucap-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gnucap"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=""
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ insinto /usr/bin
+ doins src/O/gnucap
+ doins ibis/O/gnucap-ibis
+
+ fperms 755 /usr/bin/gnucap
+ fperms 755 /usr/bin/gnucap-ibis
+
+ cd doc
+ dodoc COPYING acs-tutorial whatisit history
+ doman gnucap.1 gnucap-ibis.1
+}