summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild')
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild
index b680b38a7fe0..bad6c696ff6d 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild,v 1.1 2010/04/20 18:41:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild,v 1.2 2010/12/16 14:32:39 jlec Exp $
EAPI="3"
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.9.21"
@@ -35,8 +35,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -106,14 +104,14 @@ src_configure() {
--libdir="${ED}"/usr/$(get_libdir)/atlas \
--incdir="${ED}"/usr/include \
-C ac "${c_compiler}" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:-'-O2'}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:-'-O2'}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
cd "${S_LAPACK}"
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} ${BLAS_LIBS}:" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} ${BLAS_LIBS}:" \
-e "s:../../blas\$(PLAT).a:${BLAS_LIBS}:" \
@@ -145,9 +143,9 @@ src_compile() {
cp -sf "${BLD_DIR}"/gentoo/liblapack.a/.libs/*.o .libs/
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} ${LDFLAGS} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) ${LDFLAGS} \
"${BLAS_LIBS}" -latlas ${flibs} \
-o "${S_LAPACK}"/SRC/liblapack.la *.lo -rpath "${EPREFIX}/${RPATH}" \
|| die "Failed to create liblapack.la"