summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild')
-rw-r--r--sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild b/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
index 18c630813f89..420eb80a8e5f 100644
--- a/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
+++ b/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild,v 1.20 2008/12/07 19:10:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild,v 1.21 2010/12/16 14:33:46 jlec Exp $
-inherit eutils autotools flag-o-matic fortran multilib
+inherit eutils autotools flag-o-matic multilib toolchain-funcs
MyPN="${PN/-reference/}"
@@ -26,9 +26,7 @@ RDEPEND="virtual/blas
S="${WORKDIR}/${MyPN}-lite-${PV}"
pkg_setup() {
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- if [[ ${FORTRANC} == if* ]]; then
+ if [[ $(tc-getFC) == if* ]]; then
ewarn "Using Intel Fortran at your own risk"
export LDFLAGS="$(raw-ldflags)"
export NOOPT_FFLAGS=-O
@@ -44,7 +42,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas):" \