summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mmtk/mmtk-2.4.6.ebuild')
-rw-r--r--sci-libs/mmtk/mmtk-2.4.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/mmtk/mmtk-2.4.6.ebuild b/sci-libs/mmtk/mmtk-2.4.6.ebuild
new file mode 100644
index 000000000000..72e068d9c1b1
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.4.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/mmtk-2.4.6.ebuild,v 1.1 2006/06/13 23:52:55 spyderous Exp $
+
+MY_P=${P/mmtk/MMTK}
+S=${WORKDIR}/${MY_P}
+
+inherit distutils
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="742"
+IUSE=""
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+HOMEPAGE="http://starship.python.net/crew/hinsen/MMTK/"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~ppc ~x86"
+
+RDEPEND="dev-python/scientificpython"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils_src_install
+
+ dodoc MANIFEST.in COPYRIGHT README*
+ cd Doc
+ dodoc CHANGELOG
+ dohtml HTML/*
+
+ dodir /usr/share/doc/${PF}/pdf
+ insinto /usr/share/doc/${PF}/pdf
+ doins PDF/*
+}