summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwsetup')
-rw-r--r--sys-apps/hwsetup/ChangeLog6
-rw-r--r--sys-apps/hwsetup/Manifest8
-rw-r--r--sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch25
-rw-r--r--sys-apps/hwsetup/hwsetup-1.0-r3.ebuild6
-rw-r--r--sys-apps/hwsetup/hwsetup-1.1.ebuild6
5 files changed, 36 insertions, 15 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index 17d9287c10aa..e729b3bac255 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/hwsetup
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.28 2005/11/18 15:20:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.29 2005/12/07 04:41:25 wolf31o2 Exp $
+
+ 07 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ files/hwsetup-1.1-gentoo.patch, hwsetup-1.0-r3.ebuild, hwsetup-1.1.ebuild:
+ Added pciutils to *DEPEND and fixing Gentoo patch.
18 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org> hwsetup-1.0-r3.ebuild,
hwsetup-1.1.ebuild:
diff --git a/sys-apps/hwsetup/Manifest b/sys-apps/hwsetup/Manifest
index b01d972d58b2..4f681b990b2c 100644
--- a/sys-apps/hwsetup/Manifest
+++ b/sys-apps/hwsetup/Manifest
@@ -1,4 +1,4 @@
-MD5 af7e4840cb27c0278615d701c54e5985 ChangeLog 4025
+MD5 006d3a1232e5d68a2bd07c7789055654 ChangeLog 4210
MD5 70141575b96009e82605b4f86fbe8758 files/digest-hwsetup-1.0-r3 64
MD5 bc002ab4509c7c318c438f86d6005c71 files/digest-hwsetup-1.1 63
MD5 eff6f85f9378f9f180386a7c34deb4c3 files/hwsetup-1.0-alsa.patch 3831
@@ -7,7 +7,7 @@ MD5 7f857bf4e30d36be2ac0f59e316dfa66 files/hwsetup-1.0-fastprobe.patch 3715
MD5 5899ca3d018df09b6e2851f3e8c2e294 files/hwsetup-1.0-gentoo.patch 3599
MD5 331c5c1b01eaee2c066608e8dd1faf71 files/hwsetup-1.1-dyn_blacklist.patch 1949
MD5 a01ba41c868d97350621a124fece8d25 files/hwsetup-1.1-fastprobe.patch 2802
-MD5 bb521633bf17c370c41a83edbcab2711 files/hwsetup-1.1-gentoo.patch 3805
-MD5 c78ad044d646a8bcd8d5e7fb547abb38 hwsetup-1.0-r3.ebuild 948
-MD5 98fcac889f86acc374cdbb49e788678a hwsetup-1.1.ebuild 987
+MD5 ad0bc16bdb6e632f71a2768e270c9372 files/hwsetup-1.1-gentoo.patch 4249
+MD5 88a71a2a79c9e7ea1e814a75b5a990a1 hwsetup-1.0-r3.ebuild 987
+MD5 d249147fab105adf24372928b1fde646 hwsetup-1.1.ebuild 1025
MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
diff --git a/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch b/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
index 2654c258281d..cff145434b78 100644
--- a/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
+++ b/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
@@ -1,7 +1,7 @@
-diff -urN hwsetup-1.1.fastprobe/hwsetup.c hwsetup-1.1/hwsetup.c
---- hwsetup-1.1.fastprobe/hwsetup.c 2005-11-17 14:27:27.000000000 -0500
-+++ hwsetup-1.1/hwsetup.c 2005-11-17 14:35:02.000000000 -0500
-@@ -23,11 +23,12 @@
+diff -urN hwsetup-1.1.orig/hwsetup.c hwsetup-1.1/hwsetup.c
+--- hwsetup-1.1.orig/hwsetup.c 2005-12-06 08:42:39.000000000 -0500
++++ hwsetup-1.1/hwsetup.c 2005-12-06 08:42:18.000000000 -0500
+@@ -23,14 +23,15 @@
#endif
#define VERSION "HWSETUP 1.1, an automatic hardware configuration tool\n" \
@@ -13,10 +13,14 @@ diff -urN hwsetup-1.1.fastprobe/hwsetup.c hwsetup-1.1/hwsetup.c
-#define XPATH "/usr/X11R6/bin/"
-#define XMODPATH "/usr/X11R6/lib/modules/drivers/"
+#define XPATH "/usr/bin/"
-+#define XMODPATH "/usr/lib/modules/drivers/"
++#define XMODPATH "/usr/lib/xorg/modules/drivers/"
#define VERBOSE_PRINT 1
- #define VERBOSE_PROMPT 2
+-#define VERBOSE_PROMPT 2
++#define VERBOSE_PROMPT 0
+
+ #define SKIP_AUDIO 1
+ #define SKIP_SCSI 2
@@ -193,7 +194,7 @@
struct xinfo *getxinfo(struct device *d)
@@ -39,6 +43,15 @@ diff -urN hwsetup-1.1.fastprobe/hwsetup.c hwsetup-1.1/hwsetup.c
if(!strncasecmp(d->driver,"Card:",5)) /* RedHat Cards-DB */
{ /* Kudzu "Cards" format */
FILE *cardsdb;
+@@ -255,7 +256,7 @@
+ char xmodule[32];
+ char fullpath[128];
+ sscanf(&buffer[7],"%31s",xmodule);
+- sprintf(fullpath,XMODPATH"%.31s_drv.o",xmodule);
++ sprintf(fullpath,XMODPATH"%.31s_drv.so",xmodule);
+ if(exists(fullpath))
+ {
+ strncpy(xi.xmodule,xmodule,sizeof(xi.xmodule));
@@ -279,9 +280,9 @@
if(*xfree3server&&!*xi.xmodule)
strncpy(xi.xserver,xfree3server,sizeof(xi.xserver));
diff --git a/sys-apps/hwsetup/hwsetup-1.0-r3.ebuild b/sys-apps/hwsetup/hwsetup-1.0-r3.ebuild
index 1a886837ffdb..4cb328f738a0 100644
--- a/sys-apps/hwsetup/hwsetup-1.0-r3.ebuild
+++ b/sys-apps/hwsetup/hwsetup-1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.0-r3.ebuild,v 1.9 2005/11/18 15:20:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.0-r3.ebuild,v 1.10 2005/12/07 04:41:25 wolf31o2 Exp $
inherit eutils
@@ -14,8 +14,10 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 -mips ppc ppc64 sparc x86"
IUSE=""
-DEPEND="sys-libs/libkudzu"
+DEPEND="sys-libs/libkudzu
+ sys-apps/pciutils"
RDEPEND="sys-libs/libkudzu
+ sys-apps/pciutils
|| ( sys-apps/hwdata-gentoo
sys-apps/hwdata
sys-apps/hwdata-knoppix )"
diff --git a/sys-apps/hwsetup/hwsetup-1.1.ebuild b/sys-apps/hwsetup/hwsetup-1.1.ebuild
index bcb3da4725d2..1def8819a46a 100644
--- a/sys-apps/hwsetup/hwsetup-1.1.ebuild
+++ b/sys-apps/hwsetup/hwsetup-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.1.ebuild,v 1.3 2005/11/18 15:20:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.1.ebuild,v 1.4 2005/12/07 04:41:25 wolf31o2 Exp $
inherit eutils
@@ -15,8 +15,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 -mips ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND="sys-libs/libkudzu"
+DEPEND="sys-libs/libkudzu
+ sys-apps/pciutils"
RDEPEND="sys-libs/libkudzu
+ sys-apps/pciutils
|| ( sys-apps/hwdata-gentoo
sys-apps/hwdata
sys-apps/hwdata-knoppix )"