summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/watchdog/watchdog-5.2.4.ebuild')
-rw-r--r--sys-apps/watchdog/watchdog-5.2.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/watchdog/watchdog-5.2.4.ebuild b/sys-apps/watchdog/watchdog-5.2.4.ebuild
new file mode 100644
index 000000000000..08f056ef636b
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.2.4.ebuild,v 1.1 2005/11/27 10:07:03 brix Exp $
+
+inherit eutils
+
+DESCRIPTION="A software watchdog"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
+SRC_URI="mirror://debian/pool/main/w/watchdog/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-sundries.patch
+ epatch "${FILESDIR}"/${PV}-uclibc.patch
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/watchdog \
+ --with-configfile=/etc/watchdog/watchdog.conf \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ dodir /etc/watchdog
+ make DESTDIR="${D}" install || die
+
+ doinitd ${FILESDIR}/watchdog
+ newconfd ${FILESDIR}/watchdog.conf.d watchdog
+}
+
+pkg_postinst() {
+ einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
+ if [[ ! -e ${ROOT}/dev/watchdog ]] ; then
+ ewarn "No /dev/watchdog found! Make sure your kernel has watchdog support"
+ ewarn "compiled in or the kernel module is loaded. The watchdog service"
+ ewarn "will not start at boot until your kernel is configured properly."
+ fi
+}