summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dnotify/ChangeLog9
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0.ebuild24
-rw-r--r--sys-apps/dnotify/files/digest-dnotify-0.18.01
-rw-r--r--sys-apps/tcb/ChangeLog9
-rw-r--r--sys-apps/tcb/files/digest-tcb-0.9.8.81
-rw-r--r--sys-apps/tcb/tcb-0.9.8.8.ebuild33
6 files changed, 73 insertions, 4 deletions
diff --git a/sys-apps/dnotify/ChangeLog b/sys-apps/dnotify/ChangeLog
index bb6326ef77bd..3d314e46eb61 100644
--- a/sys-apps/dnotify/ChangeLog
+++ b/sys-apps/dnotify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dnotify
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/ChangeLog,v 1.14 2004/11/03 03:23:40 gustavoz Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/ChangeLog,v 1.15 2005/07/17 13:33:52 vapier Exp $
+
+*dnotify-0.18.0 (17 Jul 2005)
+
+ 17 Jul 2005; Mike Frysinger <vapier@gentoo.org> +dnotify-0.18.0.ebuild:
+ Version bump.
03 Nov 2004; Gustavo Zacarias <gustavoz@gentoo.org> dnotify-0.16.0.ebuild,
dnotify-0.17.1.ebuild, dnotify-0.5.0.ebuild:
diff --git a/sys-apps/dnotify/dnotify-0.18.0.ebuild b/sys-apps/dnotify/dnotify-0.18.0.ebuild
new file mode 100644
index 000000000000..5a30c181189b
--- /dev/null
+++ b/sys-apps/dnotify/dnotify-0.18.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/dnotify-0.18.0.ebuild,v 1.1 2005/07/17 13:33:52 vapier Exp $
+
+DESCRIPTION="Execute a command when the contents of a directory change"
+HOMEPAGE="http://www.student.lu.se/~nbi98oli/dnotify.html"
+SRC_URI="http://www.student.lu.se/~nbi98oli/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc -sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) || die "failed to configure"
+ emake || die "failed to make"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS TODO NEWS README
+}
diff --git a/sys-apps/dnotify/files/digest-dnotify-0.18.0 b/sys-apps/dnotify/files/digest-dnotify-0.18.0
new file mode 100644
index 000000000000..70ba29e024a8
--- /dev/null
+++ b/sys-apps/dnotify/files/digest-dnotify-0.18.0
@@ -0,0 +1 @@
+MD5 7af869cee7e07b10817c4e7918ad0aee dnotify-0.18.0.tar.gz 187909
diff --git a/sys-apps/tcb/ChangeLog b/sys-apps/tcb/ChangeLog
index 66ef69077260..b5e7466728d7 100644
--- a/sys-apps/tcb/ChangeLog
+++ b/sys-apps/tcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/tcb
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/ChangeLog,v 1.6 2004/10/02 15:33:32 swegener Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/ChangeLog,v 1.7 2005/07/17 13:36:45 vapier Exp $
+
+*tcb-0.9.8.8 (17 Jul 2005)
+
+ 17 Jul 2005; Mike Frysinger <vapier@gentoo.org> +tcb-0.9.8.8.ebuild:
+ Version bump.
*tcb-0.9.8.7 (08 Jan 2004)
diff --git a/sys-apps/tcb/files/digest-tcb-0.9.8.8 b/sys-apps/tcb/files/digest-tcb-0.9.8.8
new file mode 100644
index 000000000000..2c3c043fb7d8
--- /dev/null
+++ b/sys-apps/tcb/files/digest-tcb-0.9.8.8
@@ -0,0 +1 @@
+MD5 bd0a10c89c1592a600f9e3d2185b012f tcb-0.9.8.8.tar.gz 36660
diff --git a/sys-apps/tcb/tcb-0.9.8.8.ebuild b/sys-apps/tcb/tcb-0.9.8.8.ebuild
new file mode 100644
index 000000000000..a680ef530631
--- /dev/null
+++ b/sys-apps/tcb/tcb-0.9.8.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/tcb-0.9.8.8.ebuild,v 1.1 2005/07/17 13:36:45 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme"
+HOMEPAGE="http://www.openwall.com/"
+SRC_URI="ftp://ftp.openwall.com/pub/projects/tcb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/pam-0.75"
+
+pkg_setup() {
+ # might want to add these into baselayout eventually...
+ for group in auth chkpwd shadow ; do
+ enewgroup ${group}
+ done
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ einfo "You must now run /sbin/tcb_convert to convert your shadow to tcb"
+ einfo "To remove this you must first run /sbin/tcp_unconvert and then unmerge"
+}