summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/util-vserver/util-vserver-0.30.215.ebuild')
-rw-r--r--sys-cluster/util-vserver/util-vserver-0.30.215.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/sys-cluster/util-vserver/util-vserver-0.30.215.ebuild b/sys-cluster/util-vserver/util-vserver-0.30.215.ebuild
index 9f4badae4cdb..c7aea21d334d 100644
--- a/sys-cluster/util-vserver/util-vserver-0.30.215.ebuild
+++ b/sys-cluster/util-vserver/util-vserver-0.30.215.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/util-vserver/util-vserver-0.30.215.ebuild,v 1.1 2008/03/17 09:16:31 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/util-vserver/util-vserver-0.30.215.ebuild,v 1.2 2008/04/13 10:24:11 hollow Exp $
WANT_AUTOMAKE="1.9"
@@ -12,20 +12,20 @@ SRC_URI="http://ftp.linux-vserver.org/pub/utils/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
IUSE=""
-DEPEND=">=dev-libs/dietlibc-0.30-r2
- dev-libs/beecrypt
+CDEPEND="dev-libs/beecrypt
net-firewall/iptables
net-misc/vconfig
- sys-apps/iproute2"
+ sys-apps/iproute2
+ || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp )"
-RDEPEND="sys-apps/iproute2
- net-misc/vconfig
- net-firewall/iptables
- dev-libs/beecrypt"
+DEPEND=">=dev-libs/dietlibc-0.30-r2
+ ${CDEPEND}"
+
+RDEPEND="${CDEPEND}"
pkg_setup() {
if [[ -z "${VDIRBASE}" ]]; then
@@ -41,6 +41,12 @@ pkg_setup() {
einfo
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-openrc.patch
+}
+
src_compile() {
econf --with-vrootdir=${VDIRBASE} \
--with-initscripts=gentoo \