summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-4.6.4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.6.4.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-devel/gcc/gcc-4.6.4.ebuild b/sys-devel/gcc/gcc-4.6.4.ebuild
index 2b9e19751c75..6cfa34199cf2 100644
--- a/sys-devel/gcc/gcc-4.6.4.ebuild
+++ b/sys-devel/gcc/gcc-4.6.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.4.ebuild,v 1.4 2013/12/24 00:59:46 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.4.ebuild,v 1.5 2014/01/19 01:51:34 dirtyepic Exp $
+
+EAPI="2"
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -18,7 +20,7 @@ SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
#end Hardened stuff
-inherit toolchain
+inherit eutils toolchain
DESCRIPTION="The GNU Compiler Collection"
@@ -34,14 +36,14 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
+src_prepare() {
if has_version '<sys-libs/glibc-2.12' ; then
ewarn "Your host glibc is too old; disabling automatic fortify."
ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
fi
- toolchain_src_unpack
+ toolchain_src_prepare
use vanilla && return 0