summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/prelink/prelink-20041123.ebuild')
-rw-r--r--sys-devel/prelink/prelink-20041123.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-devel/prelink/prelink-20041123.ebuild b/sys-devel/prelink/prelink-20041123.ebuild
new file mode 100644
index 000000000000..ddf775208634
--- /dev/null
+++ b/sys-devel/prelink/prelink-20041123.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20041123.ebuild,v 1.1 2005/02/11 23:20:31 lanius Exp $
+
+inherit eutils
+
+DESCRIPTION="Modifies executables so runtime libraries load faster"
+HOMEPAGE="ftp://people.redhat.com/jakub/prelink"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha"
+IUSE=""
+
+DEPEND=">=dev-libs/elfutils-0.94
+ !dev-libs/libelf
+ >=sys-libs/glibc-2.3.2-r9
+ >=sys-devel/binutils-2.13.90.0.10"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-20040707-init.patch
+ echo -e \
+ "PRELINK_PATH_MASK=/usr/lib/wine:/usr/lib/valgrind\nPRELINK_PATH=\"\"" \
+ > ${S}/60prelink
+}
+
+src_compile() {
+ econf || die "Configure failed"
+ emake || die "Make Failed"
+}
+
+src_install() {
+ einstall || die "Install Failed"
+
+ dodoc INSTALL TODO ChangeLog THANKS COPYING README AUTHORS NEWS
+
+ insinto /etc/env.d
+ doins ${S}/60prelink
+}
+
+pkg_postinst() {
+ env-update
+ echo
+ einfo "You may wish to read the Gentoo Linux Prelink Guide, which can be"
+ einfo "found online at:"
+ einfo " http://www.gentoo.org/doc/en/prelink-howto.xml"
+ echo
+}