summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index b7485f811626..40fae773b0c6 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.11 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.12 2005/05/17 22:33:51 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -69,7 +69,7 @@ RDEPEND="virtual/os-headers
# until amd64's 2004.3 is purged out of existence
PDEPEND="amd64? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
# We need to be able to set alternative headers for
# compiling for non-native platform
@@ -1011,6 +1011,7 @@ EOF
# simple test to make sure our new glibc isnt completely broken.
# for now, skip the multilib scenario. also make sure we don't
# test with statically built binaries since they will fail.
+ [[ ${CBUILD} != ${CHOST} ]] && return 0
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})