summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch')
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch b/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch
new file mode 100644
index 000000000000..680d5f9c5975
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch
@@ -0,0 +1,28 @@
+--- anyterm-1.1.8/apachemod/Makefile 2005-10-31 22:20:05.000000000 +0100
++++ anyterm/apachemod/Makefile 2006-01-23 16:45:26.000000000 +0100
+@@ -60,10 +60,10 @@
+ cd $(COMMON_DIR); $(MAKE)
+
+ %.lo: %.cc
+- $(LIBTOOL) --mode=compile g++ $(CC_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile $(CXX) $(CC_COMPILE_FLAGS) -o $@ -c $<
+
+ %.lo: %.c
+- $(LIBTOOL) --mode=compile gcc $(C_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile $(CC) $(C_COMPILE_FLAGS) -o $@ -c $<
+
+
+ compile: $(OBJS) $(COMMON_LIB)
+@@ -73,10 +73,10 @@
+ $(APXS2) -n anyterm -i anyterm.la
+
+ %.d: %.cc
+- g++ -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CXX) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ %.d: %.c
+- gcc -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CC) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ DEPENDS=$(addsuffix .d,$(basename $(OBJS)))
+