summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/mambo/mambo-4.5.4-r2.ebuild')
-rw-r--r--www-apps/mambo/mambo-4.5.4-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/mambo/mambo-4.5.4-r2.ebuild b/www-apps/mambo/mambo-4.5.4-r2.ebuild
new file mode 100644
index 000000000000..94d13318c870
--- /dev/null
+++ b/www-apps/mambo/mambo-4.5.4-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.5.4-r2.ebuild,v 1.1 2006/09/12 03:50:33 rl03 Exp $
+
+inherit webapp depend.php
+
+WEBAPP_MANUAL_SLOT="yes"
+SLOT=4.5.4
+MY_PN="${PN/m/M}"
+DESCRIPTION="Mambo is yet another CMS"
+HOMEPAGE="http://www.mamboserver.com/"
+SRC_URI="http://mamboxchange.com/frs/download.php/8203/${MY_PN}v${PV}_wSP2.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+S=${WORKDIR}
+
+IUSE="mysql"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ virtual/httpd-php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components
+ images images/banners images/stories mambots mambots/content mambots/search
+ media language administrator/modules administrator/templates cache modules
+ templates"
+
+ dodoc CHANGELOG.php INSTALL.php README
+
+ cp -R [^d]* ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}